Follow

Installing UC-One

UC-One Communicator is available for Mac OS, Windows, iOS and Android for for Unified Communications.

Communicator for Desktop is the native Windows or Mac client, providing the following communication features:

  • Instant Messaging and Presence
  • Voice Calling (VoIP via the desktop app)
  • Voice Calling (VoIP via the desk phone)
  • Video Calling
  • Desktop Sharing
  • BroadWorks Call Settings

This client requires an active user account with Unified Communications features enabled to login.

     Windows Download

     Mac OS Download

To sign-in to the app, enter your BroadWorks username and password provided to you by your company's administrator or reach out to our support team.  (Typically, this looks like 3105551212@yourcompany.com / Y0urP@ssw0rd!)

For the Mobile client, go to either the App Store or Google Play store, depending on your smartphone, and look for "UC1 Communicator".  There are many versions of this application so be sure to get the one highlighted below and install it.

 

UC1_App.png

 

System requirements for Desktop use are as follows:

Operating system:  Mac OS 10.10 Yosemite, Mac OS 10.11 El Capitan, Mac OS 10.12 Sierra, Mac OS 10.13 High Sierra, Windows 7, Windows 8/8.1, or Windows 10 (Classical view only).

  • The installation footprint is approximately 125 megabytes (MB) on OS X and 215 MB on Windows.
  • For voice calls, a sound card, speakers, and a microphone or a headset are required.
  • For video calls, a webcam is required.

Minimum system requirements for respective operating systems need to be fulfilled, with the following additions:

  • A minimum of 2 GB random access memory (RAM) is required.
  • A minimum 1.5 GHz CPU is recommended.
  • A dual core CPU is recommended for video calls at a minimum.
  • Open Graphics Library (OpenGL) 1.5 or higher is recommended.

For high definition (HD) video, the following is recommended:

  • HD camera
  • HD resolution support in display
  • Quad Core x86 or equivalent at a minimum
  • 4 GB RAM

VDI environments are not supported.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request
Powered by Zendesk